OpenCV multiple version on Linux ENV script of setting

I have multiple version of OpenCV, 2.4.13 and 3.1.0, on my Ubuntu 14.04.4 LTS. The developted applications depends on either one. To keep all the OpenCV versions, I wrote a script to set corresponding environment.

The body of my script is showing below:

#!/bin/bash

CV_PREFIX=/usr/local/opencv

if [ $# -eq 0 ] ; then
echo "Usage : setcv.sh 2.4.13 or setcv.sh 3.1.0"
else
if [ $1 != 2.4.13 -a $1 != 3.1.0 ] ; then
echo "wrong version"
else
echo Setting for OpenCV-$1
cp ${CV_PREFIX}/$1/lib/pkgconfig/opencv.pc /usr/local/lib/pkgconfig/opencv.pc
cp ${CV_PREFIX}/OpenCV-$1.conf /etc/ld.so.conf.d/
ldconfig
fi
fi

You can run it with sudo

and you have to create two files: OpenCV⑵.4.13.conf and OpenCV⑶.1.0 to set the path of runtime libraries of the specified OpenCV.

For example:

/usr/local/opencv/2.4.13/lib

Have fun!

波比源码 – 精品源码模版分享 | www.bobi11.com
1. 本站所有资源来源于用户上传和网络,如有侵权请邮件联系站长!
2. 分享目的仅供大家学习和交流,您必须在下载后24小时内删除!
3. 不得使用于非法商业用途,不得违反国家法律。否则后果自负!
4. 本站提供的源码、模板、插件等等其他资源,都不包含技术服务请大家谅解!
5. 如有链接无法下载、失效或广告,请联系管理员处理!
6. 本站资源售价只是赞助,收取费用仅维持本站的日常运营所需!
7. 如遇到加密压缩包,请使用WINRAR解压,如遇到无法解压的请联系管理员!

波比源码 » OpenCV multiple version on Linux ENV script of setting

发表评论

Hi, 如果你对这款模板有疑问,可以跟我联系哦!

联系站长
赞助VIP 享更多特权,建议使用 QQ 登录
喜欢我嘛?喜欢就按“ctrl+D”收藏我吧!♡